RuneScript, RuneTracker, & Pseudonymania Bug Tracker
bug.rscript.org Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000009RuneScript IRC bot[All Projects] Feature Suggestionpublic2012-12-11 17:242018-03-03 22:31
Reporteranonymous 
Assigned To 
PrioritynoneSeverityfeatureReproducibilityN/A
StatusclosedResolutionwon't fix 
Summary0000009: Check D&D status, etc.
DescriptionI have absolutely no idea how the RuneScape Game Bar's data features work, but it'd be awesome if you guys were somehow able to figure out how it works, how to get the data access token, and then allow runescript to store this token and use it to allow checking of D&D status, etc.
TagsNo tags attached.
Attach Tags (Separate by ",")
Attached Files

- Relationships

-  Notes
(0000016)
Cruiser (administrator)
2012-12-11 22:48

Interesting idea. If the bar requires a login using your runescape account to access the data we'd need whatever session ID the bar uses each and every time it changes, which may not be practical.

Someone would need to do some digging to figure that out though, I've never used said bar.
(0000017)
Matt (developer)
2012-12-12 00:43

It does require a login, and a token. Unless they changed it from when I used to use it.
(0000018)
Cruiser (administrator)
2012-12-12 22:56

RuneScape login = not doable via IRC. We would have to make it a stand alone tool like Pseudonymania that runs locally to protect the credentials, which would be rather useless when you already have the toolbar.

With that said, closey closey. Not viable.
(0000028)
anonymous (reporter)
2012-12-15 18:26

You need to log in to authorize it, but I think it then just generates a token that's usable by itself, and if that token can be gotten somehow, the bot could use it.
(0000029)
spling (administrator)
2012-12-15 18:56

Couldn't we login for this information the same way we do with !name?
(0000030)
Cruiser (administrator)
2012-12-15 19:18
edited on: 2012-12-15 19:18

!name allows one account to do lookups for any request. If the toolbar API ties the data output to the account used to log into the bar in any way we aren't going to be able to do this via IRC. Even if we could use the active session ID, the user would still have to get it from the toolbar and provide it to use, which most people won't have a clue how to do.

Someone needs to install the toolbar and do some sniffing to find the API and any auth functions it uses. If we can pull data for anyone using just our account or if its in the clear it would be viable but any kind of ties to the toolbar session isn't going to work.

(0000082)
Cruiser (administrator)
2012-12-18 19:38
edited on: 2012-12-18 19:47

Properly implemented sessions don't simply let you copy and paste the ID to log in as someone else. While Jagex's forums allowed this for quite a while, they eventually fixed it so only the browser that initially logged in was allowed to use the session ID. Its safe to assume the toolbar will do the same in some form, thereby locking us out of said session, until we can verify otherwise. This is why I doubt this will work.

As I said before, there is also the problem of users *getting* that session ID/token if we're ever to try building this in that way.

While its an interesting idea, the odds of it being viable are very low unless the data feeds are 100% in the clear and we can do lookups by RS name. Until that is verified, there is no point discussing this further.

(0000083)
micksam7 (administrator)
2012-12-18 19:41

Because this sounds like we would have to handle other people's login tokens, I say this is probably a very bad thing[!] to even attempt.
(0000084)
anonymous (reporter)
2012-12-19 10:15

If you'd need login tokens the same way that the runescape website and forums work, then I agree, it wouldn't be viable. I doubt that it can be done by RS name, but IMHO it's likely that the toolbar has its own login token, that just gives read access to the D&D, friends list, and GE offers. As long as the token is just for those things and doesn't give access to the rest of the website, nor to account settings (and I don't think it does, because unlike the website login tokens, this one is good forever and doesn't require refreshing), I don't see a problem with storing and using those. Getting the token might be a little tricky, but it's probably possible to build a program that will snag it the same way the game bar does, and turn it into text that can be given to the bot.
(0000085)
spling (administrator)
2012-12-19 16:28

As noted above, since this suggestion would require us having a user-specific security token, this suggestion is unfortunately not viable. Thanks for the suggestion, but this will not be added.

- Issue History
Date Modified Username Field Change
2012-12-11 17:24 anonymous New Issue
2012-12-11 22:48 Cruiser Note Added: 0000016
2012-12-11 22:48 Cruiser Status new => acknowledged
2012-12-12 00:43 Matt Note Added: 0000017
2012-12-12 22:56 Cruiser Note Added: 0000018
2012-12-12 22:56 Cruiser Status acknowledged => closed
2012-12-12 22:56 Cruiser Resolution open => no change required
2012-12-12 23:24 anonymous Tag Attached: game bar
2012-12-15 18:26 anonymous Note Added: 0000028
2012-12-15 18:26 anonymous Status closed => feedback
2012-12-15 18:26 anonymous Resolution no change required => reopened
2012-12-15 18:56 spling Note Added: 0000029
2012-12-15 19:18 Cruiser Note Added: 0000030
2012-12-15 19:18 Cruiser Note Edited: 0000030 View Revisions
2012-12-17 04:36 anonymous Issue cloned: 0000033
2012-12-18 09:33 anonymous Note Added: 0000081
2012-12-18 09:33 anonymous Status feedback => new
2012-12-18 19:38 Cruiser Note Added: 0000082
2012-12-18 19:38 Cruiser Status new => feedback
2012-12-18 19:41 micksam7 Note Added: 0000083
2012-12-18 19:47 Cruiser Note Edited: 0000082 View Revisions
2012-12-19 10:15 anonymous Note Added: 0000084
2012-12-19 10:15 anonymous Status feedback => new
2012-12-19 16:28 spling Note Added: 0000085
2012-12-19 16:28 spling Status new => closed
2012-12-19 16:28 spling Resolution reopened => no change required
2013-02-13 23:47 anonymous Tag Detached: game bar
2015-08-15 04:15 anonymous Status closed => feedback
2015-08-15 04:15 anonymous Resolution no change required => reopened
2015-09-11 19:37 anonymous Tag Attached: '3
2015-09-11 19:38 anonymous Note Deleted: 0000081
2015-09-13 03:17 Cowman Status feedback => closed
2015-09-13 03:17 Cowman Resolution reopened => won't fix
2018-03-03 22:31 anonymous Tag Detached: '3


Copyright © 2000 - 2012 MantisBT Group
Time: 0.0092 seconds.
memory usage: 1,557 KB
Powered by Mantis Bugtracker